read

As you are no doubt aware the EU General Data Protection Regulation (Regulation 2016/679), or GDPR for short, will come into effect on May 25th 2018. As part of your compliance work you might wonder what impact using Fooman Connect: Xero has.

We have prepared the below chart to help with your assessment:

Flowchart: Fooman Connect: Xero monthly users need to upgrade

Upgrade Instructions

If you are on Magento 1 please download the latest release from your account and install the upgrade the same way you initially installed the extension. During the upgrade please make sure that the existing Fooman Connect: Xero extension files are overwritten with their newer version.

If you are on Magento 2 to upgrade our Xero integration please run the below commands from the command line:

bin/magento deploy:mode:set developer (if in production mode)
composer require fooman/connect-sub-m2:^6.2 --no-update
composer update fooman/*
bin/magento setup:upgrade
bin/magento deploy:mode:set production (if you started in production mode)

or if you are using the standalone version and are looking to upgrade to the latest version please run

bin/magento deploy:mode:set developer (if in production mode)
composer require fooman/connect-m2:^6.2 --no-update
composer update fooman/*
bin/magento setup:upgrade
bin/magento deploy:mode:set production (if you started in production mode)

If you are using the self-hosted approach (installation Option 2 in our installation guide) please download the latest zip file from your account on our website first (then unzip the bundle file and place the individual zip files into vendor/fooman/packages before running the above commands).

For further details on Xero itself and GDPR please read their resources here.

Blog Comments powered by Disqus.
Kristof Ringleff

Kristof Ringleff

Founder and Lead Developer at Fooman


Published

Want to receive our monthly email with the best Magento developer tips, tricks and news? Join 7000+ other Magento developers